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Introduction  

If somebody asks you which part of your computer is the most important, youôll undoubtedly answer ï a 

hard disk. You can change many things in your PC but a hard disk needs a special treatment because it keeps 

the most valuable ï your information. As any important thing a hard disk requires your care. Giving some 

consideration to it you are able to increase efficiency of your work.  

 

So, how can you optimize the disk system? A common problem that often decreases the disk efficiency is 

non-optimal allocation of files, the so-called file fragmentation. Under some inevitable circumstances the 

system keeps fragments of a file in different places of the disk, what significantly slows down reading 

operations. To defragment files, it is sometimes necessary to re-write them more compactly. It resembles 

threading beads ï file fragments are gathering one by one, after that the system will spend less time on 

reading the file.  

 

There are many solutions for the file fragmentation problem. Total DefragÊ is one of them. It is a reliable 

tool, which provides 27 defragmentation strategies and uses unique low-level optimization algorithms (see 

the complete list of key features). Despite the complicity of tasks Total Defrag has an easy-to-use interface. 

Moreover the present manual will help you to find the answers to many of the technical questions, which 

might arise while using the program. 

Key Features  

Let us list some of the key features:  

 

Ç User-friendly interface. Easily understood icons accompany all functions of the program. 

Ç 27 different defragmentation strategies for optimal speed increase. A properly chosen strategy allows 

setting the procedure in full accordance with the user needs. Your choice might depend on a size of 

used files, number of directories and frequency of files update. 

Ç Two modes of execution (fast and safe) to suit the needs of any user. 

Ç Unique low-level file system defragmentation and optimization algorithms enable to operate disks of 

different file systems. 

Ç Defragmentation of the Master File Table (MFT) and system metadata, options, which are usually 

not available for standard system utilities (although their optimization increases the file system 

performance). 

Ç Defragmentation of files that are located on USB 2.0 and IEEE 1394 (Fire Wire) drives (fixed drives 

only, not removable ones).  

Ç Low free space defragmentation (less than 1% free space required) lets you defragment almost full 

disks. 

Ç Detailed file fragmentation statistics on any partition. The user can analyze file allocation with a map 

where the file structure is represented in a bright graphical form.   

Ç Exhaustive reports on every defragmentation procedure with the ability to save it on a disk for 

further analysis. 

Installation  

This chapter provides information, which is needed to perform the correct installation of the program, and in 

addition, checks if the current installation is working correctly.  

Minimum System Requirements  
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To use the program on a computer satisfactorily, ensure that it meets the following minimum system 

requirements: 

Ç Operating systems: Windows 2000/XP/Vista   

Ç Internet Explorer 5.0 or higher  

Ç Intel Pentium CPU or its equivalent, with 300 MHz processor clock speed 

Ç 128 MB of RAM required (256 MB or more recommended) 

Ç Hard disk drive with 20 MB of available space 

Ç Supports USB 2.0 and IEEE 1394 (Fire Wire) drives 

Installation Procedure 

The installation process consists of the following steps: 

 

1. Run Setup Application 

From the folder, where the setup files are kept, run the SETUP.EXE file. This application will guide the user 

through the process of the program installation. The setup utility is compiled with the InstallShield SDK, 

hence it contains the standard user interface and set of installation steps. 

 

2. Starting Setup 

The Welcome page informs that the application is being installed. Click the Next button to continue. 

 

3. Confirm License Agreement 

The License Agreement page displays the Paragon License Agreement. Read the agreement and then click 

the Yes button to accept. If the user does not agree with any conditions stated there, the installation process 

will be interrupted. 

 

4. Select an Installation Folder 

The Destination Location page allows the user to choose the folder where the program will be installed. By 

default, the installation folder will be created as: 

 

C:\Program Files\Paragon Software\Paragon Total Defrag 2008. To select another folder, click the 

Browse button. 

 

After you have selected the required folder, click the Next button to continue. 

 

5. Select a Program Group 

 

The Program Folder page enables the user to select the application's program group for the Start Menu. By 

default, it will be the program group: 

 

Start > Programs > Paragon Total Defrag 2008. 

 

Click the Next button to continue. 

 

6. Verify Setup Settings 

 

The Start Copying page allows the user to verify settings, which have already been made and correct them if 

necessary. Press the Back button to return to the previous page and modify the installation settings. Click the 

Next button to complete the installation process. 

 

7. Copying Files 

 



Paragon Total DefragÊ  2010  

 
5 User Manual 

 

CopyrightÉ 1994-2010 Paragon Software Group. All rights reserved. 

The Setup Status page shows the overall progress of the installation. Click the Cancel button to abort the 

setup. 

 

8. Finishing the Installation 

 

The Final page reports the end of the setup process. Components included in the package are ready to use 

immediately after completing the installation process. 

Basic Concepts  

This chapter explains terms and ideas that show how the program works. To understand these helps to obtain 

a general notion of the operation performance and makes it easier for the user to operate the program. 

A Hard Disk Layout  

Before optimizing any system we need to understand it. Speaking about a file system of your computer we 

should picture how files are stored on a hard disk.  

In appearance a hard disk resembles a set of mirror-smooth CD/DVDs or platters (they are even called the 

same). Every disk platter is divided to tracks and sectors. Tracks are concentric circles. Sectors are radial 

wedges. Mentioning a track and a sector we can easily find any place on the disk: 

 

 
 

Sectors have a fixed size and contain a certain number of bytes (512, for example), which depends on an 

operating system.  

 

As in the case of platters a computer starts reading (or writing) information from external tracks. The main 

reason for that is the next ï a hard disk works faster on these tracks (having a permanent angular velocity we 

have the maximal linear velocity exactly on the external tracks). Please pay your attention on this important 

fact. If you keep data recorded in the beginning of the disk, it will be found and operated faster than data 

kept on the internal tracks. 
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Dividing the disk to tracks and sectors are named low-level formatting. However before we are able to place 

our files on the disk we should create special high-level structures, which help to organize our records and to 

manage them. Similar structures form a file system. When we are performing high-level formatting, we are 

creating such structures as a file allocation table (FAT), data blocks (where our future files can be stored) 

and some others.  

File Fragmentation  

A wish to optimize the hard disk work might be caused by many reasons ï from a simple habit to put a place 

in order to unpleasant occurrences of system failures. But any way a main obstacle you meet here will be the 

progressive fragmentation of files. Data is written irregularly on the disk. The same file might be stored in 

different sectors. While updating files, the system tends to save updates on the largest continuous space of 

the hard disk. This space is often on a sector different from sectors where the other parts (fragments) of the 

file are stored. In the case of fragmented files the system has to search the hard disk every time the file is 

opened to find all of its fragments what noticeably slows down the response time.  

 

 
 

Service files of operating systems may be also fragmented. The NTFS file system has for example a special 

fil e, the Master File Table (MFT), which is a well-organized catalogue of all files on a partition. The table 

keeps records about every file allocation, about its attributes and even contents of small size files. MFT is a 

system file, which is stored on a protected part of the NTFS partition (the so-called MFT zone). Usually the 

$MFT file is inaccessible for standard defragmentation tools (not for Total Defrag!) although it is subject to 

fragmentation as any other file.  
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Defragmentation  

The medicine against the fragmentation is evident. We should rewrite different parts of any file to 

contiguous sectors on the hard disk. This process is called defragmentation. It often helps to increase the 

speed of file access and data retrieval. 

 

 
 

Total Defrag enables to re-write files in an optimal way depending on peculiarities of the file system and on 

your tasks. So it allows taking into account the following conditions: 

Ç If you work with big size files (multimedia or CAD files are usually big), then it is reasonable to 

place them into those sectors of the disk where your computer could operate them faster, i.e. to the 

first sectors of the disk. It might be done during the defragmentation procedure (see the 

Defragmenting Partition chapter).   

Ç If a hard disk has a great number of directories (for example it may be a data base or your favorite 

music collection), then you should also place directories on the sectors with the highest disk 

performance to make search files faster. 

Ç And at least placing most frequently updating files to the first sectors of the disk will provide the 

performance increase too.     

Before starting the defragmentation procedure we also recommend to draw your attention to 

PAGEFILE.SYS and HIBERFIL.SYS system files that are used in the NTFS system as the temporary ones. 

They are re-initialized at the beginning of every Windows session and they are absolutely unimportant 

between the sessions. Excluding them from the processing files you save time. 

Interface Overview  

This chapter introduces the graphical interface of the program. The design of the interface precludes any 

mistake being made on the part of the user. Buttons and menus are accompanied by easy understandable 

icons. Nevertheless, any problems that might occur while managing the program can be tackled by reading 

this very chapter. 

General Layout  

When the user starts the program, the first component that is displayed is called the Launcher. It enables the 

user to run wizards and utilities, to specify program settings, to visualize the operating environment and the 

hard disk configuration. 
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The Launcherôs window can be conditionally subdivided into several sections that differ in their purpose and 

functionality: 

 

1. Main Menu  

2. Tool Bar  

3. Defragment Operations Bar  

4. Common Tasks Bar   

5. Defragment Map 

6. Disk Map  

7. Disk Map Legend 

8. Status Bar  

 

Some of the panels have similar functionality with a synchronized layout. The program enables the user to 

conceal some of the panels to simplify the interface management. 

 

All panels are separated by vertical and horizontal expandable sliders, allowing the user to customize the 

screen layout. 

Main Menu 

The Main Menu provides access to the entire functionality of the program. The available functions are as 

listed below: 

MENU ITEM FUNCTIONALITY 

Tools   

Recovery Media Builder... Defragment the system even when the current operating system cannot boot 
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Check Recovery Discs... 

Verify the recovery media is a CD/DVD disc, a USB flash card or even a 

floppy disk from which you can boot for maintenance or recovery purposes. 

for integrity and ability to boot from 

Settings Edit the general settings of the program 

Exit Exit the program 

Changes   

Reload Disk Info Refresh the current information about disks 

Partition    

Analyze Fragmentation 

Display the structure of partition blocks in the form of the 

Defragmentationmap 

Defragment Partitioné Perform the defragmentation process for a chosen partition 

Defragment MFTé Perform the defragmentation of the MFT file (for a NTFS partition) 

Compact MFT Perform the MFT compacting procedure for a chosen NTFS partition 

Test surfaceé Perform the surface test for a chosen partition 

Check File System Integrity Perform the integrity test for a chosen partition 

Properties Display properties of the selected partition 

View   

Toolbar 
Manage the Tool bar representation: show / hide standard buttons, text 

labels and large icons. 

Status Bar Display the Status bar 

Common Tasks Bar Display the Common tasks bar 

Disk Map Legend Display the Disk map legend 

Defragmentation Map Display the Defragmentation Map 

Disk Map Location 
Select whether the Disk map will be located on the top of the main window 

or at the bottom 

Help   

Help Open the Help system 

About Open the dialog with information about the program 

Tool Bar 

The Toolbar provides fast access to the most frequently used operations: 

BUTTON  FUNCTIONALITY  

 
Perform the integrity test for a file system  

 
Perform the MFT shrinking for an NTFS partition 

 
Open the Help system 

Defragment Operations Bar  

The Defragment Operation Bar enables to manage the defragmentation procedure. 
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BUTTON  FUNCTIONALITY  

 

Analyze the fragmentation. The program displays the current 

structure of partition blocks in form of the Defragmentation map.   

 
Start the defragmentation procedure for a partition.  

 
Start the MFT defragmentation procedure for an NTFS partition. 

Common Tasks Bar 

The Common Tasks Bar is located on the left side of the main window. It is intended for easy access to 

Tools, News, Help System, Web References and other documentation. 

The bar contains a tabs called Tools and News and Documentation, which can be folded by clicking it. 

Tools   

 

Starting the Recovery Media Builder Wizard to create a 

Linux/DOS bootable media which can be used to get access to 

your partitions for defragmentationpurposes. 

 

Starting the Check Recovery Disk Wizard to verify recovery 

media for integrity and ability to boot from. 

News and Documentation   

 

Launching the Help system. 

 

Opening the page, which contains information about the 

program. 

Disk Map 

The Disk Map is displayed when the Disk View tab is selected. It is located either at the top or at the bottom 

of the window, depending on the state of the Disk Map Location option (Main menu: View > Disk Map 

Location). The user can change the current location of the map with this option. 

As the name infers, the Disk Map displays the layout of physical and logical disks. Physical disks are 

represented with rectangle bars that contain small-sized bars. These small-sized bars represent logical disks. 

Their color depends on the file system of the appropriate partition. 

 

Large-sized bars display the following information about physical disks: 

Ç       Manufacturer, 
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Ç       Model. 

Small-sized bars display the following information about logical disks: 

Ç       Serial number, 

Ç       Drive letter, 

Ç       Total size, 

Ç       File system. 

Furthermore, it is possible to estimate the used disk space by looking at the size of the barôs shaded area. 

Disk Map is synchronized with the Defragment Map. When the user selects a disk on the Disk Map the 

Defragment Map display detailed information of the selected disk. 

Legend Bar 

The Legend Bar explains the color scheme used for disk and partition presentation. The user can hide (or 

show) the bar with the appropriate Main menu item: View > Disk Map Legend. When it is activated it can be 

found at the bottom of the window. 

 

The program distinguishes between the following types of known file systems: 

 

   - FAT16/32,  

   - NTFS, 

- Linux Ext2/3,  

- Linux ReiserFS. 

Defragment Map 

Defragment Map is another helpful tool that enables the user to get a clear-cut picture of the current state of 

the file system. The map represents the structure of blocks for a partition, which has been selected in the 

Disk Map. The disk name will be displayed at the top part of the bar. Below the disk name the user sees the 

Defragment Map itself. Block colors depend on their types. The correspondence between a color and a block 

type is in the map legend. 

 

When the user starts the defragmentation procedure, there is the ability to see how the program re-writes file 

fragments more compactly and disk blocks change their colors from red to green.     

Furthermore, the Defragment Map is synchronized with the Disk Map. 
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Status Bar  

This is the bottom part of the main window. The status bar displays menu hints, for each item the cursor 

points to. 

 

The user can hide (or show) the bar with the appropriate Main menu item: View > Status bar. 

Settings Overview 

The Settings dialog is available from the Main menu: File > Settings. All the settings are grouped into 

several sections of which the functions are described in the following paragraphs. The list of sections is 

placed on the left side of the dialog. By selecting a section from the list, the user opens a set of options. 

Defragmentation Options 

 

In this section you can set the preferable mode of the program execution.  Actually youôve got two options: 

Ç       Fast mode. Partitions will be defragmented rather fast (10-30% gain depending on the data 

fragmentation), but a power outage, hardware malfunction or a system failure during the operation 

might lead to the data loss. 

Ç       Safe mode. To guarantee protection of your data during the operation, the program will allocate 

some free space (not less than the on-disk largest file) on the defragmented at the moment partition 

to make a duplicate of every processed file. Thus we strongly recommend you to use this very mode.  

How to Optimize a File System  
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This chapter lists various scenarios of disk system optimization, which might be accomplished by the 

program. This has already been reviewed in the Basic concepts chapter. Here the user will find more useful 

recommendations and descriptions of operations.  

Analyzing Disks  

To begin with, let us examine the current situation of the available disk space. The program provides some 

helpful tools for this purpose. 

Analyzing File Fragmentation 

The program allows analyzing the fragmentation of any partition that has been selected in the Disk Map. For 

a preliminary estimate the Defragment Map can be used. It represents the current structure of partition 

blocks in the graphic form. 

 

Blocks are colored in accordance with their types ï free, fragmented, writing, reading, used and blocks of 

unsupported file systems. Fragmented blocks are well noticeable ï theyôre red. The more red-marked blocks 

the greater extent of the fragmentation. If fragmented blocks content more than 50 per cent, it is reasonable 

to accomplish the defragmentation procedure. 

To get more exact information, the user should take the following steps:   

1. Select a partition on the Disk Map. 

2. Start the special analyzing procedure. There are several ways to do it: 

Ç       Select in the Main menu: Partition > Defragment > Analyze Fragmentation 

Ç       Click the Analyze fragmentation button in the Defragment Operation Bar. 

Results of the analysis will be displayed in a new dialog. 
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They include the exact value of the fragmentation (in percents) and the detailed information about 

fragmented files. To get the last, just click the button Show Files Fragmentation Details. 

  

 
  

The information contains: 

Ç       A number of file fragments 

Ç       Size of fragments 

Ç       Names of fragmented files. 

To close this part of the dialog, click the Hide Files Fragmentation Details. There is also the possibility to 

save analysis reports into a file on the disk by clicking the Save button. 

Viewing Partition Properties 

The program enables to obtain in-depth information on the properties of hard disks/partitions. Besides the 

general information, such as capacity, used space or file system type it provides the possibility to get info on 

a hard disk geometry, cluster size, exact partition location, etc. 

In order to view properties of a partition/hard disk the user should take the following steps: 

1. Select a partition/hard disk on the Disk Map. 
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2. Call the Properties dialog. There are several ways to do it: 

Ç       Select in the Main menu: Partition > Propertiesé 

Ç       Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Propertiesé 

 

3. The provided information is grouped according to its properties, thus select the required tab and get the 

information you need. 

Testing Disk Surface 

The disk analysis may also include surface tests. The program allows performing these tests on existing 

partitions. 

In order to start the surface test the user should take the following steps: 

1. Select a partition on the Disk Map. 

2. Call the Test Surface dialog to define appropriate settings. There are several ways to do it: 

Ç       Select in the Main menu: Partition > Test Surfaceé 

Ç       Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Test Surfaceé 
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Surface test level. Choose the level of the test procedure. 

3. The operation will be performed immediately after confirmation. 

Checking File System Integrity 

The program enables to check the file system integrity on existing partitions. This function can be used for 

detecting file system errors before performing operations on a partition. Some operations (such as the 

defragmentation) require the targeted partition to have a valid file system to be processed. 

In order to start the system integrity check the user should take the following steps: 

1. Select a partition on the Disk Map. 

2. Call the Check File System Integrity dialog to define appropriate settings. There are several ways to do it: 

Ç       Select in the Main menu: Partition > Check File System Integrity. 

Ç       Click the Check File System Integrity button in the Toolbar. 

Ç       Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Check File System Integrity. 

 

3. The operation will be performed immediately after confirmation. 

Defragmenting Partition 

Defragmentation is the process of rewriting different parts of a file (its fragments) to contiguous sectors of a 

hard disk to increase the speed of file access and retrieval (see the Basic concepts chapter for more details). 

The program provides a necessary tool for the defragmentation of NTFS and FAT partitions of a hard disk. 

 

The user must have administratorôs privileges to accomplish the defragmentation of the 

system partition. 














