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INTRODUCTION 

The system maintenance and data protection issues are becoming exponentially more complex as the company itself grows. 
Obvious lack of IT personnel on site leads to inevitable problems caused by shortage of resources and knowledge required to 
adequately manage and back up valuable data. The possible consequences are easy to predict - that is operational, litigation, 
and compliance risks that few companies can afford. When problems do occur, getting everything back on track may take days 
to accomplish, thus resulting in lost revenue, lost opportunity and even customer loyalty. 

Paragon Remote Management, a specially designed solution for a centralized administration and maintenance of computer 
parks, recognizes those unique needs and helps you address them. It provides the possibility to remotely assign various tasks to 
a single computer or groups of computers and check whether this or that particular task has been a success. Besides a one-time 
execution it enables to automatically set operations on a regular basis. In general, Paragon Remote Management is particularly 
powerful in tackling the following issues: 

 Data loss protection (backup/restore operations); 

 Hard disk re-equipment/replacement (clone partition/hard disk). 

With our solution you will dramatically boost efficiency by reducing resource requirements and costs. 

In this manual you will find the answers to many of the technical questions which might arise while using the program. 

WHAT’S NEW IN PARAGON REMOTE MANAGEMENT? 

 Remote installation/de-installation of clients directly from PRM Console to increase the overall usability; 

 Built-in facilities to create answer files (.mst generator) for remote unattended installation; 

 New format for PRM Storage to increase the overall efficiency and stability with the option to easily upgrade from the 
old version; 

 Paragon Connection Control to effectively manage load to the PRM Storage server; 

 Advanced reporting facilities to manually or automatically according to a set timetable collect statistics on every action 
accomplished on client machines; 

 Service Live Tracker to automatically recover PRM Client in case it’s been de-activated. 

PRODUCT COMPONENTS 

Paragon Remote Management contains several components: 

 PRM Console to effectively manage client machines (remote installation/de-installation, tasks and task templates 
creation, clients grouping and supervision, etc.); 

 PRM Client to establish data exchange between a remote computer and PRM Storage and to initiate scheduled tasks. 

KEY FEATURES 

Let us list some of the key features: 

 Remote installation/de-installation of clients directly from PRM Console to increase the overall usability; 
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 Built-in facilities to create answer files (.mst generator) for remote unattended installation; 

 Paragon Connection Control to effectively manage load of the PRM Storage server; 

 Advanced reporting facilities to manually or automatically according to a set timetable collect statistics on every action 
accomplished on client machines; 

 Service Live Tracker to automatically recover PRM Client in case it’s been de-activated; 

 Task Scheduler to automate routine operations; 

 Clients grouping to increase efficiency; 

 Support for task templates to minimize the operation time and costs; 

 Ready-made task templates for the most frequently used operations. 

PRODUCT ARCHITECTURE 

Paragon Remote Management is a complex enterprise level remote disk management solution, designed to simplify and 
automate routine maintenance tasks for a single computer or groups of computers. 

The product structure is shown on the scheme below: 

 

As you can see the PRM infrastructure involves interaction of several components: 

 Administrator Workstation is a computer of the IT Administrator, who controls the PRM infrastructure. This machine 
has Paragon software installed to create task script files; 

 PRM Console is a user friendly application to effectively manage client machines (remote installation/de-installation, 
tasks and task templates creation, clients grouping and supervision, etc.); 
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 PRM Storage is a shared directory on PRM Server (specially designated computer) to keep information on separate 
clients, groups of clients, assigned tasks, tasks templates as well as reports sent by clients and logs sent by executors; 

 PRM Client is a service to establish data exchange between a remote computer and PRM Storage and to initiate 
scheduled tasks; 

 PSL Script (Paragon Scripting Language) is a text file, which contains commands interpreted and performed by the 
program engine of PRM Client. It can be created manually in a text editor, or with Paragon Drive Backup; 

 File Server is an optional repository. PRM clients can store backup images to this server through a shared folder; 

 Microsoft Networks Protocol is used by PRM to exchange data on the network, provide access to PRM Storage and 
store backup images. 

To get a better notion of the principles the program works on, let us just look at its components a bit closer. 

PRM CONSOLE 

PRM Console provides a user-friendly interface to effectively manage PRM Storage and PRM Clients: 

 Set an existing PRM Storage; 

 Install/De-install PRM Clients remotely; 

 Group certain clients; 

 Create tasks for separate clients, groups of clients or all clients of PRM Storage; 

 Create task templates; 

 Create tasks from the ready-made templates; 

 Collect statistics on every action accomplished on client machines manually or automatically according to a set 
timetable. 

PRM STORAGE 

PRM Storage is used as a repository for keeping statistics on registered clients, assigned tasks, created groups and task 
templates as well as reports sent by clients and logs sent by executors. Actually it is a shared directory of a strictly defined 
structure that contains certain files. 

PRM SHARED DIRECTORY STRUCTURE 

To dispose PRM Storage it is needed to choose a shared network resource (shared directory) that can be accessed read/write by 
one or several network users, thus allowing the console and clients to access that shared resource on behalf of these users. To 
work properly the PRM shared directory name should be known both to the console and clients besides it requires initialization, 
which will automatically be accomplished with the console the moment a new database is created. After that a client(s) can 
register in the storage creating subdirectory with the name of its MAC address. 
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The PRM shared directory may only contain some certain types of files (psd.ini, task.ini, executor logs, task scripts). 

PRM CLIENT 

PRM Client is responsible for data exchange between a remote computer and PRM Storage. Besides it initiates scheduled tasks 
by using an independent scheduling mechanism (no system scheduler is required). It works as a service in the system and is 
launched at the system startup. In general it is to retrieve a task(s) from the storage and calculate the execution time according 
to the schedule. When the time comes it downloads the task script and launches the script interpreter. After the script 
interpreter is accomplished it transmits to the storage the resulted report and the executor log (if any). 

EXECUTORS 

In fact operations are carried out with executors located on remote computers. The current version of the program only 
provides support for one executor type, i.e. Paragon Script Interpreter, thus just one task type is available – accomplishment of 
PSL scripts. 
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Actually the executor combines the script interpreter (SCRIPTS.EXE) and several auxiliary modules to operate locked partitions 
(BlueScreen and HotBackup). During the operation the script interpreter creates a set of files, one of which (STUBACT.LOG) will 
later be transmitted to the storage. 

TASKS 

Any task in the PRM framework comprises several parts: 

 PSL script describing operations to carry out; 

 The execution schedule; 

 Reports/Logs of executors; 

 The task description and its identification data. 

Tasks can be assigned to a separate client (an individual task), groups of clients (a group task) or all clients registered in PRM 
Storage (a common task). 

GETTING STARTED 

In this chapter you will find all the information necessary to get the product ready to use. 

SYSTEM REQUIREMENTS 

Before installing the product, please make sure it meets the following minimum system requirements: 

 Operating systems: Windows 2000/XP/Vista/Server 2000/2003/2008 and XP SP2/Vista/Server 2003/2008 64-bit 

 Internet Explorer 5.0 or higher 

 Intel Pentium CPU or its equivalent, with 300 MHz processor clock speed 

 128 MB of RAM 

 Hard disk drive with 20 MB of available space 

 Network Interface Card (NIC): 100 Mbps and higher 

 

Please make sure a computer, which will act as PRM Server, can be accessed read/write, and has got 
enough free space since it will be used to store client backup images, execution scripts, and 
operation logs. 

PRODUCT INSTALLATION 

You’ve got the choice to install the PRM components (Console or/and Client) automatically through the Windows Active 
Directory services, or manually. Below we will dwell upon the manual installation scenario as the most common one. 

 

The current version of the product offers the option to remotely install PRM Clients directly from 
PRM Console. To do that, you need to have an .mst answer file, which can be generated with the 
installation package. Please note however that if you’ve already installed the product, you won’t be 
able to run the installation package once again on the same computer to generate an .mst file, only 
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vice versa. 

To get a step-by-step guide on the automatic installation through the Windows Active Directory services, please go to the 
company’s website. 

Manual installation of the product involves several steps: 

 Accomplishment of a number of preparatory actions before initiating installation; 

 Installation of the product. 

PREPARATORY ACTIONS 

1. Choose a computer, which will act as PRM Server. Please make sure it provides high network performance, since 
simultaneous backup of a bunch of client computers to PRM Server will certainly require all available network 
resources. 

2. On that computer create a shared directory (PRM Storage in terms of the program) that can be accessed read/write. 
Since this is the place where client backup images, execution scripts, and operation logs will later be kept, make sure 
the partition containing that directory has got enough free space. 

 

3. Give access rights to PRM Storage correctly according to the Windows policies. Actually you’ve got two options: 

In Domain 

 You need to create only one user (PRMAgent in our case) and make it a member of the Domain Admins group. 
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 Set Domain Admins as the primary group by clicking the appropriate button and then remove PRMAgent from the 
Domain Users group. 

 

When done, PRMAgent will be authorized as a domain administrator on every client machine of the domain. 

 
It’s not absolutely necessary to make that user a domain administrator, but in this case you will need 
to add it to the local administrators group on computers, where it’s planned to install the PRM 
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Client. 

 This is actually the user you need to provide read/write access rights to PRM Storage. 

 

 

Both options guarantee, that only a special user and administrators will have access to client tasks, backup images and other 
information. Moreover, dealing with the domain configuration, you can even restrict access only to Domain Computers. 

It’s up to administrators to set up the security policies. The principal here is that the user, on behalf of which PRM Client will 
operate on client computers, can have read/write access rights to PRM Storage. 

In Workgroup 

 On every computer, where you’re going to install PRM Client, create one and the same user (PRMAgent in our 
case). 
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If you’re going to install both the client and the console on PRM Server, you need to create the same 
user on that computer as well. 

 Add that user to the local administrators group (it’s absolutely necessary to make our program work on a client 
computer). 
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 This is actually the user you need to provide read/write access rights to PRM Storage. 
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4. Make sure, the server and all clients are available to browse in the network, either a workgroup or domain. 

5. Make sure, that the IT Administrator user account, on which behalf PRM Console will work of, has permanent access to 
the PRM Storage network share. 

INSTALLATION 

1. Click on the PRM.MSI file to initiate installation. 

 

If you’ve already got PRM Console prior 2.0, please save custom templates and psd.ini which stores 
info on the created client groups, otherwise this data will be lost during the product installation. 

2. The Welcome page will inform that the application is being installed. Click Next to continue. 

3. Please Read Paragon License Agreement carefully and then select the appropriate option to accept. Otherwise you 
won’t be able to proceed with the installation. 

 

4. On the next page you can see two options: 

 Install the product on this computer physically (that’s what we need in our case); 

 Go through the installation wizard virtually to generate an .mst file required for unattended installation. Thus 
you will need this one only when going to remotely install PRM Clients through PRM Console. 
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5. Provide the standard customer information, i.e. a user name and an organization. Besides you need to decide whether 
to make the program available for all users of this computer (if several) or only for the current one. 

 

6. The next page enables to select what components to install and where. 

 

Call the popup menu for the required item (left click of the mouse button on the icon), then select whether to install 
the component or not. A brief description to the selected feature and approximate disk space needed to install it will be 
displayed on the right, thus precluding any mistake being made on the part of the user. 

 

To know more on how to select particular components to install, please click the Help button. 

It’s highly recommended not to install PRM Console on PRM Server (a computer with PRM Storage). 

PRM Console Alone 

 If only the console is being installed, please specify the PRM Storage directory on a network share; 
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 Choose the preferred format for PRM Storage. If you’ve already got clients prior to version 2.0, please select 
Use legacy storage format for compatibility. After upgrading all your clients to version 2.0+, you will be able to 
easily convert PRM Storage to the new format from the console. If not, we highly recommend you to use the 
new format for PRM Storage as it’s more stable and resource efficient; 

 

 

If you’re going to place PRM Console and PRM Storage on different computers, please make sure 
that the IT Administrator user account, on which behalf PRM Console will work of, has got 
permanent access to the PRM Storage network share. 

PRM Console with PRM Client 

 If both the client and the console are being installed on the same computer, please specify the PRM Storage 
directory on a network share. 
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 Choose the preferred format for PRM Storage. If you’ve already got clients prior to version 2.0, please select 
Use legacy storage format for compatibility. After upgrading all your clients to version 2.0+, you will be able to 
easily convert PRM Storage to the new format from the console. If not, we highly recommend you to use the 
new format for PRM Storage as it’s more stable and resource efficient; 

 

 Browse the computer (when in a workgroup) or the domain and then choose the required user (the one you 
made at the preparatory step). 

 

 Enter the user password. 
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If you’re going to place PRM Console and PRM Storage on different computers, please make sure 
that the IT Administrator user account, on which behalf PRM Console will work of, has got 
permanent access to the PRM Storage network share. 

PRM Client Alone 

 Specify the PRM Storage directory by browsing the network. 

 

 

 

Don’t forget to log in to the client computer as a user that can have read/write access rights to PRM 
Storage (either the user we created at the preparatory step (PRMAgent), or a domain administrator 
(for domains). Otherwise you won’t be able to specify the PRM Storage directory. 

 Browse the computer (when in a workgroup) or the domain and then choose the required user (the one you 
made at the preparatory step). 
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 Enter the user password. 

 

7. On the Ready to Install the Program page click Install to start the installation or Back to return to any of the previous 
pages and modify the installation settings. 

8. The Final page reports the end of the setup process. Click Finish to complete the wizard and restart the computer for 
the changes to take effect. 

 

Providing the access rights to the shared directory and users are properly set up, after the 
installation has been completed, all client computers will automatically be registered in PRM Storage 
(for every client will be created a separate directory with the name of its MAC address) and be 
available in PRM Console (with their NetBIOS names). 

CONTACTING PARAGON TECHNOLOGY GMBH 

If you have any questions about the company products, please do not hesitate to contact Paragon Technology GmbH. 

Service Contact 

Visit Paragon GmbH web site www.paragon-software.com 

Registration & updates web-service kb.paragon-software.com 

Knowledge Base & Technical Support kb.paragon-software.com 

Pre-sale information sales@paragon-software.com 

PRM CONSOLE FUNCTIONALITY 

http://kb.paragon-software.com/�
http://kb.paragon-software.com/�
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In the given section you can find all the information necessary to successfully work with PRM Console. 

INTERFACE OVERVIEW 

PRM Console offers a user-friendly interface that helps to effectively accomplish required operations while minimizing the 
possibility of making any mistake. Operations are performed through the system of dialogs. Buttons and menus are 
accompanied by easy understandable icons. Nevertheless, any problems that might occur while managing the program can be 
tackled by reading this very chapter. 

GENERAL LAYOUT  

When you start the program, the first component that is displayed is called the Main Window. It enables to run dialogs, to 
specify program settings, and to visualize the operating environment. 

The Main Window can be conditionally subdivided into several sections that differ in their purpose and functionality: 

 

1. Main Menu 

2. Tool Bar 

3. Operations Bar 

4. Templates Bar 

5. Status Bar  
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MAIN MENU  

The Main Menu provides access to the entire functionality of the program. The available functions are as listed below: 

MENU ITEM  FUNCTIONALITY  

Task 

New Task… Starting the Create a New Task dialog to create a new task 

Change Task… Starting the Change Task dialog to modify parameters of the 
selected task 

Delete Task… This option enables to delete the selected task 

Create From 
Task Template 

Starting the Create a New Task From Task Template dialog to 
create a new task based on a ready-made template 

New Task 
Template… 

Starting the Create a New Task Template dialog to create a new 
template 

Change Task 
Template… 

Starting the Change Task Template dialog to modify parameters 
of the selected template 

Delete Task 
Template… 

This option enables to delete the selected template 

Exit  Exit the program 

Client 

Change 
Client… 

Starting the Change Client Properties dialog to modify 
properties of the selected client 

Explore 
Client… 

Starting Windows Explorer to get access to the selected client’s 
subdirectory located in PRM Storage 

Install Clients… Starting the Browse for Available Clients dialog to remotely 
install new clients 

Uninstall 
Clients… 

Starting the Browse for Installed Clients dialog to remotely de-
install clients 

New Group… Starting the Create New Group dialog to create a new group of 
clients 

Change 
Group… 

Starting the Change Group dialog to modify properties of the 
selected group of clients 

Delete Group… This option enables to delete the selected group of clients 

Delete All 
Tasks… 

This option enables to cancel all assigned tasks 

View 

Refresh Refresh contents of the Operations Bar 

Expand All Show details on all tasks available at the moment 

Collapse All Hide details on all tasks available at the moment 

Clients and 
Groups 

Display all available clients and groups and their properties 

Tasks Display all available tasks and their properties 

Status Bar Show/Hide the Status Bar 

Task 
Templates 

Show/Hide the Templates Bar 

Settings... Edit the program settings 

Tools  

Generate 
Report… 

Manually collect statistics on every action accomplished on 
client machines 
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Schedule 
Report… 

Set a timetable to collect statistics automatically 

Convert PRM 
Storage… 

Convert PRM Storage to the new format 

Help 

Contents Open the program help 

About  Open the dialog with information about the program  

 

 

The Main Menu contents dynamically change depending on the active pane (Clients and Groups or 
Tasks) at the moment. 

TOOL BAR  

The Toolbar provides fast access to the most frequently used operations: 

BUTTON  FUNCTIONALITY  

 Create a new task 

 
Create a new task from the selected 
task template 

 Modify parameters of the selected task 

 Delete the selected task 

 Create a new group 

 
Modify properties of the selected 
group 

 Delete the selected group 

 Refresh contents of the Operations Bar 

 
 Manually collect statistics on every 
action accomplished on client machines 

 
Set a timetable to collect statistics 
automatically 

 Display the Clients and Groups pane 

 Display the Tasks pane 
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The Tool Bar contents dynamically changes depending on the active pane (Clients and Groups or 
Tasks) at the moment. 

OPERATIONS BAR 

The Operations Bar is located in the center of the main window that emphasizes its importance. Depending on the defined 
settings, the Operations Bar may display the Client and Groups Pane or the Tasks Pane. 

CLIENT AND GROUPS PANE 

The Client and Groups pane enables to manage clients (modify client properties, group clients according to performed tasks, 
etc.). 

 
To know more on how to manage clients, please consult the Managing Clients chapter. 

TASKS PANE 

The Tasks pane allows the user to manage tasks (create new tasks or task templates, modify or delete existing templates, edit 
task scripts, etc.). 

 
To know more on how to manage tasks, please consult the Managing Tasks chapter. 

TEMPLATES BAR 
In the Templates Bar you can see all available task templates. By calling a popup menu for the selected template it is possible to 
create a new task based on it or modify/delete it. Besides you’re offered the option to create new templates. 
 
You can hide (or show) the bar with the appropriate Main Menu item: View > Task Templates. 
 

 
To know more on how to manage templates, please consult the Managing Tasks chapter. 

STATUS BAR  

This is the bottom part of the main window. The status bar displays menu hints, for each item the cursor points to. 

You can hide (or show) the bar with the appropriate Main Menu item: View > Status Bar. 

SETTINGS 

The Settings dialog is available from the Main Menu: View > Settings.  
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With its help you can specify the following parameters: 

Program Folders 

- Path to PRM Storage. If you’d like to change the default location of PRM Storage, please manually enter a full path to 
the required shared directory or click Browse to look for it. 

- Path to PRM Reports. If you’d like to change the default location of reports generated by PRM, please manually enter a 
full path to the required location or click Browse to look for it. Besides you can specify a time frame within which 
reports are to be generated. 

Server Load Control 
 

- Maximum of connections per session. If many of PRM clients are scheduled to back up to PRM Storage simultaneously 
(more than 9), it’s highly recommended to specify the default maximum of connections per session to effectively 
manage load to the PRM Storage shared directory, thus overcoming one the main drawbacks of a peer-to-peer 
connection. So clients over the specified limit will be delayed until vacant slots appear.  

- Maximum of client delay period. By setting the maximum time frame for delayed clients you can avoid the situation 
when clients waiting for vacant slots cannot initiate the other scheduled tasks. 

 

 
Your changes will take effect only after the program restart. 

MANAGING TASKS 

PRM Console provides all the facilities needed to manage tasks (create new tasks or task templates, modify or delete existing 
templates, edit task scripts, etc.). 

CREATING NEW TASKS 

There are several ways to create a new task: 

 In the Main menu: select Task > New Task… 
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 In the Toolbar: click the New Task button 

 Call the popup menu for the selected client/group (right click of the mouse button) in the Clients and Groups pane and 
then choose the menu item: New Task… 

 

The mentioned above option is only available when the Clients and Groups pane is active (Main 
menu: View > Clients and Groups). 

After following one of the above mentioned actions, the Create a New Task dialog will be displayed. 

 

Create a new task defining: 

Task Properties 

 Name. Type in a name of the task. 

 Description. Describe the task to easily understand its purpose. 

 Script File. Press the Browse button to look for the required script or set a full path to it manually. 

Scheduling 

Thanks to the embedded Scheduler, you can set a timetable for execution of your task. By selecting one of the available time 
options, the scheduler displays a form that enables to set a timetable: 

 Once. Mark the option to define the date and time when the task is to be launched. 
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 Daily. Mark the option to define the time when the task is to be launched, a period during which the operation will be 
performed (in days), the date when the operation will be started first and the date after which the operation will be 
deleted from the scheduler's waiting list. 

 Weekly. Mark the option to define the time when the task is to be launched, a period during which the operation will 
be performed (in weeks), days of the week, when the operation will be started, the date when the operation will be 
started for the first time and the date when the operation will cease to run. 

 Monthly. Mark the option to define the time when the task is to be launched, a day of a month when the operation 
starts, the date when the operation will be started for the first time and the date when the operation will cease to run. 

 Become Obsolete After. If a client is off-line at the moment of initiating the task, but is on within the time frame 
specified here, the task can still be launched. If not, the task will be marked obsolete. 

Server Load Control 

If your task is for a group of clients (more than 9) scheduled to back up to PRM Storage, please mark the option to activate 
Paragon Connection Control. You can use the default maximum of connections per session specified in the Settings dialog or set 
the required value from the drop down list. 

 

By clicking the Create button you will receive a newly created task available in the Tasks pane. 

MODIFYING TASKS 

There are several ways to modify the selected task: 

 In the Main menu: select Tasks > Change Task… 

 Click the Change Task link in the Tasks pane 

 Call the popup menu for the task (right click of the mouse button) in the Tasks pane and then choose the menu item: 
Change Task… 

 

 

The mentioned above options are only available when the Tasks pane is active (Main menu: View > 
Tasks). 

After following one of the above mentioned actions, the Change Task dialog will be displayed. Its work algorithm is practically 
the same as with the Create a New Task dialog, except you can see all the previously set parameters of the selected task to make 
the necessary modifications. 
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Modify the selected task defining: 

 Name. Modify the task name. 

 Description. Modify the task description. 

 Script File. Press the Edit Script… button to open and modify the selected script with Windows Notepad. 

 Scheduling. Modify the time of execution. 

 Server Load Control. Choose whether to use Paragon Connection Control or not. 

By clicking the Change button you will receive a modified task available in the Task pane. 

DELETING TASKS 

There are several ways to delete the selected task: 

 In the Main menu: select Tasks > Delete Task… 

 Click the Delete Task link in the Tasks pane 

 Call the popup menu for the task (right click of the mouse button) in the Tasks pane and then choose the menu item: 
Delete Task… 
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The mentioned above options are only available when the Tasks pane is active (Main menu: View > 
Tasks). 

After following one of the above mentioned actions, you will be offered to confirm deletion of the selected task. 

 

CREATING NEW TASKS FROM TASK TEMPLATES 

There are several ways to create a new task from an existing task template: 

 In the Main menu: select Task > Create From Task Template… 

 In the Toolbar: click the Create From Task Template button 

 Call the popup menu for the selected client/group (right click of the mouse button) in the Clients and Groups pane and 
then choose the menu item: Create From Task Template 

 

The mentioned above option is only available when the Clients and Groups pane is active (Main 
menu: View > Clients and Groups). 

 Call the popup menu for the selected template (right click of the mouse button) in the Templates pane and then choose 
the menu item: Create Task From Template 

 

The mentioned above option is only available when the Task Templates pane is active (Main menu: 
View > Task Templates). 

After following one of the above mentioned actions, the Create a New Task From Task Template dialog will be displayed. 
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Create a new task from an existing task template defining: 

Task Properties 

 Task Template. Select a template from the drop down list. By default there will be selected one active at the moment. 

 Name. After selecting the required template, the program automatically offers an easy to understand name containing 
the template name itself and the current date. It also leaves the possibility to do it manually. 

 Description. By default the program offers the template description that can also be modified. 

 Script File. By default the program uses the template script. Press the Browse button to look for some other script or 
set a full path to it manually. 

Scheduling 

Thanks to the embedded Scheduler, you can set a timetable for execution of your task. By selecting one of the available time 
options, the scheduler displays a form that enables to set a timetable: 

 Once. Mark the option to define the date and time when the task is to be launched. 

 Daily. Mark the option to define the time when the task is to be launched, a period during which the operation will be 
performed (in days), the date when the operation will be started first and the date after which the operation will be 
deleted from the scheduler's waiting list. 
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 Weekly. Mark the option to define the time when the task is to be launched, a period during which the operation will 
be performed (in weeks), days of the week, when the operation will be started, the date when the operation will be 
started for the first time and the date when the operation will cease to run. 

 Monthly. Mark the option to define the time when the task is to be launched, a day of a month when the operation 
starts, the date when the operation will be started for the first time and the date when the operation will cease to run. 

 Become Obsolete After. If a client is off-line at the moment of initiating the task, but is on within the time frame 
specified here, the task can still be launched. If not, the task will be marked obsolete. 

Server Load Control 

If your task is for a group of clients (more than 9) scheduled to back up to PRM Storage, please mark the option to activate 
Paragon Connection Control. You can use the default maximum of connections per session specified in the Settings dialog or set 
the required value from the drop down list. 

 

By clicking the Assign button you will receive a newly created task based on the selected task template. 

CREATING TEMPLATES 

There are several ways to create a new template: 

 In the Main menu: select Tasks > New Task Template… 

 Call the popup menu in the Task Templates pane (right click of the mouse button) and then choose the menu item: 
New Task Template 

 

 

The mentioned above option is only available when the Task Templates pane is active (Main menu: 
View > Task Templates). 

After following one of the above mentioned actions, the Create a New Task Template dialog will be displayed. 
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Create a new task template defining: 

Name and Script 

 Name. Type in a name of the task. 

 Description. Describe the task to easily understand its purpose. 

 Script File. Press the Browse button to look for the required script or set a full path to it manually. 

Server Load Control 

If your task template is for a group of clients (more than 9) scheduled to back up to PRM Storage, please mark the option to 
activate Paragon Connection Control. You can use the default maximum of connections per session specified in the Settings 
dialog or set the required value from the drop down list. 

By clicking the Create button you will receive a newly created task template available in the Task Templates pane. Once a new 
task template is made you can use it to assign a new task. 

MODIFYING EXISTING TEMPLATES 

There are several ways to modify the selected task template: 

 In the Main menu: select Tasks > Change Task Template… 

 Call the popup menu for the selected template (right click of the mouse button) in the Task Templates pane and then 
choose the menu item: Change Task Template… 

 

 

The mentioned above option is only available when the Task Templates pane is active (Main menu: 
View > Task Templates). 

After following one of the above mentioned actions, the Change Task Template dialog will be displayed. Its work algorithm is 
practically the same as with the Create a New Task Template dialog, except you can see all the previously set parameters of the 
selected template to make the necessary modifications. Besides it is possible to modify the selected script. 
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Modify the selected task template defining: 

Name and Script 

 Name. Modify the template name. 

 Description. Modify the template description. 

 Script File. Press the Browse button to look for the required script or set a full path to it manually. 

 Script Modification. Press the Edit Script… button to open and modify the selected script with Windows Notepad. 

Server Load Control 

If your task template is for a group of clients (more than 9) scheduled to back up to PRM Storage, please mark the option to 
activate Paragon Connection Control. You can use the default maximum of connections per session specified in the Settings 
dialog or set the required value from the drop down list. 

By clicking the Change button you will receive a modified template available in the Task Templates pane. 

DELETING TEMPLATES 

There are several ways to delete the selected task template: 

 In the Main menu: select Tasks > Delete Task Template… 

 Call the popup menu for the selected template (right click of the mouse button) in the Task Templates pane and then 
choose the menu item: Delete Task Template… 

 

 

The mentioned above option is only available when the Task Templates pane is active (Main menu: 
View > Task Templates). 

After following one of the above mentioned actions, you will be offered to confirm deletion of the selected template. 
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MODIFYING SCRIPTS 

A script file is just a textual file where operations are described with macro-language commands of the Paragon Scripting 
Language. The program installation package contains an interpreter utility - SCRIPTS.EXE that works in the unattended mode and 
enables to automate operations. 

You’ve got the option to modify scripts either when modifying tasks or task templates. 

 

Please consult the Paragon Scripting Language manual that comes with Paragon Drive Backup to 
know more on the subject. 

MANAGING CLIENTS 

With PRM Console you can easily manage clients (modify client properties, group clients according to performed tasks, etc.). 

MODIFYING CLIENT PROPERTIES 

There are several ways to modify properties of the selected client: 

 In the Main menu: select Clients > Change Client… 

 Call the popup menu for the selected client (right click of the mouse button) in the Clients and Groups pane and then 
choose the menu item: Change Client… 

 

 

The mentioned above option is only available when the Clients and Groups pane is active (Main 
menu: View > Clients and Groups). 

After following one of the above mentioned actions, the Change Client Properties dialog will be displayed. You can see all the 
previously set parameters of the selected client to make the necessary modifications. 

 

Modify properties of the selected client defining: 

 Name. Modify the client name. 

 Description. Modify the client description. 

By clicking the Change button you will receive a modified client available in the Clients and Groups pane. 
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EXPLORING CLIENTS 

There are several ways to explore contents of the selected client’s subdirectory: 

 In the Main menu: select Clients > Explore Client… 

 Call the popup menu for the required client (right click of the mouse button) of the Clients and Groups pane and then 
choose the menu item: Explore Client… 

 

The mentioned above option is only available when the Clients and Groups pane is active (Main 
menu: View > Clients and Groups). 

After following one of the above mentioned actions, by employing the Windows Explorer facilities you will get access to the 
required folder (its name actually is the client’s MAC address) located in PRM Storage. 

 

You can see several files and all existing network backups (if any) there: 

 task.ini where the client properties (name, description, etc.) and information on the assigned tasks (task name, 
description, used script, time of execution, current status, etc.) are listed. For ease of use the latest task assigned to the 
client is automatically placed closer to the top of the page just below the client properties; 

 *.log that contains in-depth information on parameters and performance of all operations carried out by the executor 
(Paragon Script Interpreter). 

These files are simple textual files that can be opened with any text editor (Windows Notepad by default). 

REMOTELY INSTALLING CLIENTS 

To remotely install new clients, please do the following: 

1. Generate an answer .mst file required for remote unattended installation. You can do it with the product installation 
package by selecting the appropriate option.  
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The work algorithm of generating an .mst file is similar to that of installing the product. The only difference is that you 
will get as a result an .mst file placed by default to c:\transform.mst, which however can be modified by manually 
entering a full path to the required location or clicking Browse to look for it. 

 

Please note however that if you’ve already installed the product, you won’t be able to run the 
installation package once again on the same computer to generate an .mst file, only vice versa. 

2. Call the Browse for Available Clients dialog to install new clients by selecting in the Main Menu: Clients > Install 
Clients… 

 

 Computers to install PRM Client. Browse for a client machine(s) you need to install (CLIENT03 in our case) and 
mark the checkbox opposite its name to select; 

 Login info. Provide Administrator’s name and password in the required fields; 

 MSI file. Manually enter a full path to the product installation package or click Browse to look for it; 

 MST file. Manually enter a full path to the generated .mst file or click Browse to look for it; 

 Scheduling. Schedule  the installation procedure (by default it will be initiated immediately after closing the 
dialog); 

 Clients Preparation. Click OK to prepare the selected client machine(s) for installation; 
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Once it’s done you can close the dialog - installation of PRM Client to the selected client machine(s) will be accomplished 
according to the set timetable. 

 

All installation steps will be automatically logged to PRM Storage as a separate file for each PRM 
Client. Thus in case of a failure, you can find out the reasons and tackle the problem. 

REMOTELY DE-INSTALLING CLIENTS 

 To remotely de-install clients, please select in the Main Menu: Clients > Uninstall Clients… 

 

 Computers to de-install PRM Client. In the opened dialog select a client(s) (CLIENT03 in our case) you need to de-install 
by marking the checkbox opposite its name; 

 Login info. Provide Administrator’s name and password in the required fields; 
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 MSI file. Manually enter a full path to the product installation package or click Browse to look for it; 

 Scheduling. Schedule  the de-installation procedure (by default it will be initiated immediately after closing the dialog); 

 Clients Preparation. Click OK to prepare the selected client machine(s) for de-installation; 

 

Once it’s done you can close the dialog – de-installation of PRM Client from the selected client machine(s) will be accomplished 
according to the set timetable. 

 

All de-installation steps will be automatically logged to PRM Storage as a separate file for each PRM 
Client. Thus in case of a failure, you can find out the reasons and tackle the problem. 

CREATING NEW GROUPS 

There are several ways to create a new group of clients: 

 In the Main menu: select Clients > New Group 

 Call the popup menu for the All Clients item (right click of the mouse button) of the Clients and Groups pane and then 
choose the menu item: New Group… 

 

 

The mentioned above option is only available when the Clients and Groups pane is active (Main 
menu: View > Clients and Groups). 

After following one of the above mentioned actions, the Create New Group dialog will be displayed. 
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Create a new group of clients defining: 

 Name. Type in a group name. 

 Description. Describe the group to easily understand its purpose. 

 Clients to join. In the left pane of the dialog, choose at least two clients you would like to have in the group from the list 
of all available clients and press the Add button. In the right pane you can see all clients of the group. You can also 
remove the selected clients from the group by pressing the Remove button. 

By clicking the Create button you will receive a new group of clients available in the Clients and Groups pane. 

MODIFYING GROUPS 

There are several ways to modify the selected group of clients: 

 In the Main menu: select Clients > Change Group… 

 Call the popup menu for the selected group (right click of the mouse button) in the Clients and Groups pane and then 
choose the menu item: Change Group… 

 

 

The mentioned above option is only available when the Clients and Groups pane is active (Main 
menu: View > Clients and Groups). 

After following one of the above mentioned actions, the Change Group dialog will be displayed. Its work algorithm is practically 
the same as with the Create New Group dialog, except you can see all the previously set parameters of the selected group to 
make the necessary modifications. 
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Modify properties of the selected group defining: 

 Name. Modify the existing group name. 

 Description. Give an additional description to the group. 

 Clients to join. In the left pane of the dialog, choose at least two clients you would like to have in the group from the list 
of all available clients and press the Add button. In the right pane you can see all clients of the group. You can also 
remove the selected clients from the group by pressing the Remove button. 

By clicking the Change button you will receive the modified group of clients available in the Clients and Groups pane. 

DELETING GROUPS 

There are several ways to delete the selected group of clients: 

 In the Main menu: select Clients > Delete Group… 

 Call the popup menu for the selected group (right click of the mouse button) in the Clients and Groups pane and then 
choose the menu item: Delete Group… 

 

 

The mentioned above option is only available when the Clients and Groups pane is active (Main 
menu: View > Clients and Groups). 

After following one of the above mentioned actions, you will be offered to confirm deletion of the selected group. 

 

GENERATING REPORTS 
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PRM Console offers advanced reporting facilities to manually or automatically according to a set timetable collect statistics on 
every action accomplished on client machines. 

MANUAL REPORT 

There are several ways to generate a report: 

 In the Main menu: select Tools > Generate Report… 

 In the Toolbar: click the Generate Report button 

After following one of the above mentioned actions, a new report will be automatically generated and placed according to a 
location set in the Settings dialog. 

 

 
Reports will be generated only for a time frame specified in the Settings dialog. 

AUTOMATIC REPORT 

There are several ways to set a timetable for automatic report generation: 

 In the Main menu: select Tools > Schedule Report… 

 In the Toolbar: click the Schedule Report button 

After following one of the above mentioned actions, the Schedule Report Generation dialog will be displayed. 
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 Time frame. Specify a time frame within which reports are to be generated. 

 Scheduling. Set the required timetable for automatic report generation. 

 Login info. If you’d like generation of reports even in the log-off mode, please follow the Specify user name and 
password link in the left lower corner of the window to provide the required user name and password on behalf of 
which the scheduled tasks will be accomplished. 

 

By clicking the Change button generation of reports will be scheduled. Click the Delete button to cancel the operation. 

CONVERTING PRM STORAGE 

If you’ve just upgraded to the latest version of our product and would like to use all the benefits it offers, we highly recommend 
you to convert PRM Storage to the new format, as it is more stable and resource efficient. 

To convert PRM Storage to the new format, please do the following: 
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1. Re-install PRM Console and select Use legacy storage format for compatibility; 

 

2. Launch the console to make sure all your clients are OK; 

 

3. Re-install your clients manually or remotely (recommended, but in this case, please do not forget to provide a path to 
the old installation package for de-installation and the new one for installation); 

4. When done, lunch the console once again to make sure all your clients have been upgraded to the latest version; 

 

5. Convert PRM Storage to the new format by selecting in the Main menu: Tools > Convert PRM Storage…; 

6. In the opened dialog confirm the operation by clicking Convert; 

 

7. In the Progress window you can see in real-time a detailed report on all actions carried out by the program. 
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TYPICAL SCENARIOS 

This chapter lists various operation scenarios that may be accomplished with Paragon Drive Backup and Paragon Remote 
Management. You can find here useful recommendations and descriptions of operations. 

INITIAL BACKUP 

In the framework of the corporate system data imaging, initial backup is indispensable when a new client joins the system or 
some client is going to swap the computer. Besides a number of companies pursue an in-house policy that from time to time 
obligates IT personnel to back up all computers to create the so called checkpoints. And finally, known as the most resource 
saving variant of initial backup is backup of the system partition only. Despite the fact that it does not guarantee protection of all 
data of a computer, it enables to protect an operating system. 

FULL BACKUP OF A HARD DISK 

To back up an entire hard disk of the required client computer(s), please do the following: 

1. Create PRM Storage on a computer which will act as PRM Server. Please make sure it provides high network 
performance, since simultaneous backup of a bunch of client computers to PRM Server will certainly require all 
available network resources; 

2. Install PRM Console on that computer or any other computer on the net; 

3. Install PRM Client on the required client machines manually or remotely with PRM Console; 

4. In PRM Console choose the required task template from the list of templates; 

 

There are several templates for this kind of operation, as you can place backups of entire hard disks 
to local disks, the Backup Capsule, or network (PRM Storage by default). 

5. In case it’s required to adopt the script to your needs, please do it with the Change Task or Change Task Template 
dialogs. Please consult the Paragon Scripting Language manual that comes with Paragon Drive Backup to know more on 
the subject; 
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6. If the template is OK, create a task for the required client(s). Call the Create From Task Template dialog and in the 
opened window select the required base template (Full backup of HDD to local drive (Backup Capsule) or Full backup of 
HDD to network), set a task name and its description; 

7. Set a timetable for the given template; 

8. According to the set schedule, the task will automatically be assigned to the required client(s). The results of execution 
will be available in PRM Console. 

Available Templates: 

 Full backup of HDD to local drive (Backup Capsule) 

 Full backup of HDD to network 

FULL BACKUP OF THE SYSTEM PARTITION 

In case there are several data partitions on client computers or some special hidden system partition, it’s often preferred not to 
back up an entire hard disk, but only the system partition, thus significantly saving space to keep backup images without any 
harm to the system data. 

To back up the system partition of the required client computer(s), please do the following: 

1. Create PRM Storage on a computer which will act as PRM Server. Please make sure it provides high network 
performance, since simultaneous backup of a bunch of client computers to PRM Server will certainly require all 
available network resources; 

2. Install PRM Console on that computer or any other computer on the net; 

3. Install PRM Client on the required client machines manually or remotely with PRM Console; 

4. In PRM Console choose the required task template from the list of templates; 

 

There are several templates for this kind of operation, as you can place backups of the system 
partition to local disks, the Backup Capsule, or network (PRM Storage by default). 

5. In case it’s required to adopt the script to your needs, please do it with the Change Task or Change Task Template 
dialogs. Please consult the Paragon Scripting Language manual that comes with Paragon Drive Backup to know more on 
the subject; 

6. If the template is OK, create a task for the required client(s). Call the Create From Task Template dialog and in the 
opened window select the required base template (Full backup of system partition to local drive (Backup Capsule) or 
Full backup of system partition to network), set a task name and its description; 

7. Set a timetable for the given template; 

8. According to the set schedule, the task will automatically be assigned to the required client(s). The results of execution 
will be available in PRM Console. 

Available Templates: 

 Full backup of system partition to local drive (Backup Capsule) 

 Full backup of system partition to network 
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BACKUP/RESTORE BY REQUEST 

In the data imaging framework the so called operations on demand are pretty much relevant, in particular when speaking about 
a one-time action that is to accomplish by request for a single client or a group of clients. Generally it may have to do with 
introducing a new client or an off-schedule request to back up/restore the system. Besides a complete or differential backup of 
the system partition can also be of great use either before installing new software or carrying out some critical system 
operations.  

DIFFERENTIAL BACKUP OF A PARTITION BY REQUEST 

Let’s consider a situation when it’s needed to carry out some critical operation on the client computer that might negatively 
affect the computer/system operation as a result of installing new software or servicing the system partition. If this is the case, 
the client should notify the system administrator about the need to back up the data (i.e. backup by request). In this particular 
scenario it’s assumed that a complete backup has already been made, thus enabling to make a differential backup. 

1. Create PRM Storage on a computer which will act as PRM Server. Please make sure it provides high network 
performance, since simultaneous backup of a bunch of client computers to PRM Server will certainly require all 
available network resources; 

2. Install PRM Console on that computer or any other computer on the net; 

3. Install PRM Client on the required client machines manually or remotely with PRM Console; 

4. In PRM Console, the Client and Groups pane, select a client/group to perform the required operation for; 

5. From the list of the Task Templates choose a template you need; 

 

There are several templates for this kind of operation, as you can place backups of the system 
partition to local disks, the Backup Capsule, or network (PRM Storage by default). 

6. Adopt the script with the Change Task or Change Task Template dialogs. Please consult the Paragon Scripting Language 
manual that comes with Paragon Drive Backup to know more on the subject; 

7. Call the Create From Task Template dialog by right click of the mouse button for a client/group; 

8. In the opened dialog type in a task name and its description, besides set a path to the previously created template; 

9. Set a timetable for the task. As soon as we deal with a one-time operation by request, it is needed to choose the Once 
item and define the time of execution; 

10. According to the schedule, the task will automatically be assigned to the required client(s) just once. The results of 
execution will be available in PRM Console. 

Available Templates:  

 Differential backup of system partition to local drive (Backup Capsule) 

 Differential backup of system partition to network 

RESTORE FROM NETWORK BY REQUEST 
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Let’s consider a situation when one of the client machines fails to boot because of a virus attack or corruption of some system 
critical files. But there’s a backup of that computer on PRM Storage. That’s just enough to easily get the client back on track 
again. 

1. Insert Paragon WinPE Recovery CD into the required client machine (the BIOS must be enabled to boot the system from 
the CD/DVD device); 

2. Restart the computer; 

3. After the disc has been loaded, you will see the Universal Application Launcher. Select Restore Wizard; 

4. On the Browse for Archive page of the wizard select the required backup image: 

 Select Network as a backup destination; 

 Map PRM Storage; 

 Choose the required backup image in the browser-like window. 

5. The What to Restore page displays detailed information about contents of the archive. Select the required item to 
restore. In our case it’s the first partition of the disk; 

6. On the Where to Restore page specify a hard disk, then one of its partitions to restore the image to (if several on the 
client’s computer). By default, the program offers to restore the archive exactly where it belongs; 

 
All contents on the partition selected for restoring purposes will be deleted during the operation. 

7. On the Restore Results page you can see the resulted disk layout. Besides there’s the possibility to change size of the 
partition and its location if necessary as well as assign a particular drive letter; 

8. After completing the operation close the wizard, take out the disc and then reboot the computer. 

 
This operation can also be accomplished with the Linux/DOS recovery environment. 

CONTINUOUS SYSTEM/DATA PROTECTION 

Continuous system and data protection implies regular backup operations according to a timetable, thus providing reliable 
protection for the clients’ system and data. A more advanced technique of regular backup is cyclic regular backup that enables 
to limit the disk space required to store images and also its maximum number, thus providing for a closed operation cycle. 

SYSTEM/DATA PROTECTION BASED ON REGULAR FULL/DIFFERENTIAL BACKUP TO NETWORK 

Let’s consider the backup operation on a regular basis to network (PRM Storage by default). Taking a remote reservoir for 
storing images, not a local computer, enables to significantly increase data reliability. This kind of operation will be of great use 
when dealing with the corporate backup system of workstations and servers. 

1. Create PRM Storage on a computer which will act as PRM Server. Please make sure it provides high network 
performance, since simultaneous backup of a bunch of client computers to PRM Server will certainly require all 
available network resources; 
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2. Install PRM Console on that computer or any other computer on the net; 

3. Install PRM Client on the required client machines manually or remotely with PRM Console; 

4. In PRM Console, the Client and Groups pane, select a client/group to perform the required operation for; 

5. From the list of the Task Templates choose a template you need; 

 

There are several templates for this kind of operation, as you can make a full backup of entire 
HDD/the system partition, or a differential backup of the system partition to network (PRM Storage 
by default). 

6. Adopt the script with the Change Task or Change Task Template dialogs. Please consult the Paragon Scripting 
Language manual that comes with Paragon Drive Backup to know more on the subject; 

7. Call the Create From Task Template dialog by right click of the mouse button for a client/group; 

8. In the opened dialog type in a task name and its description, besides set a path to the previously modified 
template; 

9. Set a timetable for the task. As soon as we deal with a regular backup operation to remote Backup Server, there are 
several available options (Daily, Weekly and Monthly); 

10. According to the schedule, the task will be regularly assigned to the required client(s). The results of execution will 
be available in PRM Console. 

 

While using this scenario please take into consideration the certain limitation - backup images stored 
on the selected network share will be either regularly overwritten or its number will be constantly 
increasing. It’s up to the system administrator to control the amount of available disk space and the 
number of backup images. To avoid this kind of inconvenience please take advantage of the Cyclic 
Regular Backup. 

Available Templates: 

 Full backup of HDD to network 

 Full backup of system partition to network 

 Differential backup of system partition to network 

SYSTEM/DATA PROTECTION BASED ON CYCLIC FULL BACKUP TO NETWORK 

Let’s consider the backup operation on a regular basis to network (PRM Storage by default) with an additional control of the 
backup data that lies in limiting the disk space to store images for a particular client and the maximum number of images that 
are allowed to store on the backup storage. 

The cyclic regular backup implies two modes of execution. In the first mode (called Basic) the program only creates complete 
backups at the same time controlling the number of images on the backup storage and the amount of the occupied disk space. 
On exceeding the maximum parameters the oldest archives will automatically be overwritten. 

In the second mode (called Differential) every first image will be made as a complete base archive and all the others will be 
differentiated from it. This operation requires much less space, thus considerably saving the system resources. The program also 
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controls the number of images on the backup storage and the amount of the occupied disk space. However, on exceeding the 
maximum parameters only the oldest differential archives will automatically be overwritten not a base (initial) image. Anyway 
it’s required to check the whole process from time to time to make sure differential archives have not become bigger than the 
base image. 

 

Taking a remote reservoir for storing images, not a local computer, enables to significantly increase 
data reliability. This kind of operation will be of great use when dealing with the corporate backup 
system of workstations and servers. 

1. Create PRM Storage on a computer which will act as PRM Server. Please make sure it provides high network 
performance, since simultaneous backup of a bunch of client computers to PRM Server will certainly require all 
available network resources; 

2. Install PRM Console on that computer or any other computer on the net; 

3. Install PRM Client on the required client machines manually or remotely with PRM Console; 

4. In PRM Console, the Client and Groups pane, select a client/group to perform the required operation for; 

5. From the list of the Task Templates choose a template you need; 

 

There are several templates for this kind of operation, as you can make a full cyclic backup of entire 
HDD/the system partition, or a differential cyclic backup of the system partition to network (PRM 
Storage by default). 

6. Adopt the script with the Change Task or Change Task Template dialogs. Please consult the Paragon Scripting 
Language manual that comes with Paragon Drive Backup to know more on the subject; 

7. Call the Create From Task Template dialog by right click of the mouse button for a client/group; 

8. In the opened dialog type in a task name and its description, besides set a path to the previously modified 
template; 

9. Set a timetable for the task. As soon as we deal with a regular backup operation to remote Backup Server, there are 
several available options (Daily, Weekly and Monthly); 

10. According to the schedule, the task will be regularly assigned to the required clients/groups. The results of 
execution will be available in PRM Console. 

Available Templates:  

 Cyclic backup of hard disk in Basic Type to network 

 Cyclic backup of system partition in Basic Type to network 

 Cyclic backup of system partition in Differential Type to network 

SYSTEM/DATA PROTECTION BASED ON CYCLIC FULL/DIFFERENTIAL BACKUP TO BACKUP CAPSULE 

Let’s consider the backup operation on a regular basis to a special hidden place (Backup Capsule) with an additional control of 
the backup data that lies in limiting the disk space to store images for a particular client and the maximum number of images 
that are allowed to store on the backup storage. This scenario will suit laptop clients who do not have permanent network 
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access, but need backup images at the immediate disposal to get the system and data back on track when being away on 
business. 

The cyclic regular backup implies two modes of execution. In the first mode (called Basic) the program only creates complete 
backups at the same time controlling the number of images on the backup storage and the amount of the occupied disk space. 
On exceeding the maximum parameters the oldest archives will automatically be overwritten. 

In the second mode (called Differential) every first image will be made as a complete base archive and all the others will be 
differentiated from it. This operation requires much less space, thus considerably saving the system resources. The program also 
controls the number of images on the backup storage and the amount of the occupied disk space. However, on exceeding the 
maximum parameters only the oldest differential archives will automatically be overwritten not a base (initial) image. Anyway 
it’s required to check the whole process from time to time to make sure differential archives have not become bigger than the 
base image. 

1. Create PRM Storage on a computer which will act as PRM Server. Please make sure it provides high network 
performance, since simultaneous backup of a bunch of client computers to PRM Server will certainly require all 
available network resources; 

2. Install PRM Console on that computer or any other computer on the net; 

3. Install PRM Client on the required client machines manually or remotely with PRM Console; 

4. In PRM Console, the Client and Groups pane, select a client/group to perform the required operation for; 

5. From the list of the Task Templates choose a template you need; 

 

There are several templates for this kind of operation, as you can make a full cyclic backup of the 
entire HDD/the system partition, or a differential cyclic backup of the system partition to Backup 
Capsule. 

6. Adopt the script with the Change Task or Change Task Template dialogs. Please consult the Paragon Scripting 
Language manual that comes with Paragon Drive Backup to know more on the subject; 

7. Call the Create From Task Template dialog by right click of the mouse button for a client/group; 

8. In the opened dialog type in a task name and its description, besides set a path to the previously modified 
template; 

9. Set a timetable for the task. As soon as we deal with a regular backup operation to the Backup Capsule, there are 
several available options (Daily, Weekly and Monthly); 

10. According to the schedule, the task will be regularly assigned to the required clients/groups. The results of 
execution will be available in PRM Console. 

Available Templates:  

 Cyclic backup of hard disk in Basic Type to Backup Capsule 

 Cyclic backup of system partition in Basic Type to Backup Capsule 

 Cyclic backup of system partition in Differential Type to Backup Capsule 

REGULAR RESTORE FROM LOCAL DRIVE 
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Let’s consider the restore operation on a regular basis from a local drive, i.e. some partition on the client computer or a special 
hidden place (Backup Capsule). For computer classes or test benches it’s often the case when a regular recovery of a bunch of 
computers is required. Please note that all the changes will be lost. 

1. In PRM Console, the Client and Groups pane, select a client/group to perform the required operation for; 

2. From the list of the Task Templates choose a template you need; 

 

There are several templates for this kind of operation, as you can restore an entire HDD or only the 
system partition. 

3. Adopt the script with the Change Task or Change Task Template dialogs. Please consult the Paragon Scripting 
Language manual that comes with Paragon Drive Backup to know more on the subject; 

4. Call the Create From Task Template dialog by right click of the mouse button for a client/group; 

5. In the opened dialog type in a task name and its description, besides set a path to the previously modified 
template; 

6. Set a timetable for the task. As soon as we deal with a regular restore operation from a local drive or the Backup 
Capsule, there are several available options (Daily, Weekly and Monthly); 

7. According to the schedule, the task will be regularly assigned to the required clients/groups. The results of 
execution will be available in PRM Console. 

Available Templates:  

 Restore system partition (backup on local drive) 

 Restore hard disk (backup on local drive) 

MIGRATION (LOCALLY) TO NEW HARDWARE 

This scenario covers the instances of data migration from one hard disk to another. When a client is going to migrate to 
a new hard disk, it’s recommended to take advantage of the HDD copy operation followed by the restore operation to 
new hardware. 

Before launching the operation, please make sure a new hard disk (where all the data will be copied to) is installed on the client 
computer. 

1. Launch PRM Console. In the Client and Groups pane choose the required client; 

2. From the Task Templates list select the Migration (locally) to new hardware by copy operation template; 

3. Adopt the script with the Change Task or Change Task Template dialogs. Please consult the Paragon Scripting 
Language manual that comes with Paragon Drive Backup to know more on the subject; 

4. If the template is OK, create a task for the client. Call the Create From Task Template dialog and in the opened 
window select the required template Migration (locally) to new hardware by copy operation, set a task name and 
its description; 

5. Set a timetable for the given template (Once, Daily, Weekly and Monthly options are available); 
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6. According to the schedule, the task will automatically be assigned to the client. The results of execution will be 
available in PRM Console. 

Available Templates:  

 Migration (locally) to new hardware by copy operation 

CUSTOMER SPECIFIC SCENARIOS  

CREATING A TASK TEMPLATE 

1. Create PRM Storage on a computer which will act as PRM Server. Please make sure it provides high network 
performance, since simultaneous backup of a bunch of client computers to PRM Server will certainly require all 
available network resources; 

2. Install PRM Console on that computer or any other computer on the net; 

3. Install PRM Client on the required client machines manually or remotely with PRM Console; 

4. Install Paragon Drive Backup; 

5. Launch Paragon Drive Backup to carry out operations you need to be performed on the client computer(s). By 
default, the program works in the virtual mode of execution, that’s why all operations will be postponed; 

6. Save the resulted set of operations in form of a script with the Generate Script dialog (Tools > Generate script…) 

7. Launch PRM Console; 

8. Adopt the script with the Change Task or Change Task Template dialogs. Please consult the Paragon Scripting 
Language manual that comes with Paragon Drive Backup to know more on the subject; 

9. To create a custom template, please right click of the mouse on the empty space of the Task Templates Bar to call 
the New Task Template dialog; 

10. In the opened dialog type in a task name and its description, besides set a path to the previously created template. 

CREATING A TASK 

1. Create PRM Storage on a computer which will act as PRM Server. Please make sure it provides high network 
performance, since simultaneous backup of a bunch of client computers to PRM Server will certainly require all 
available network resources; 

2. Install PRM Console on that computer or any other computer on the net; 

3. Install PRM Client on the required client machines manually or remotely with PRM Console; 

4. Install Paragon Drive Backup; 

5. Launch Paragon Drive Backup to carry out operations you need to be performed on the client computer(s). By default, 
the program works in the virtual mode of execution, that’s why all operations will be postponed; 

6. Save the resulted set of operations in form of a script with the Generate Script dialog (Tools > Generate script…) 

7. Launch PRM Console; 
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8. Adopt the script with the Change Task or Change Task Template dialogs. Please consult the Paragon Scripting Language 
manual that comes with Paragon Drive Backup to know more on the subject; 

9. Select a client/group to carry out the task for; 

10. Call the New Task Template dialog by right click of the mouse button (or from the Main Menu: New Task) for a 
client/group; 

11. In the opened dialog type in a task name and its description, besides set a path to the previously created template. 

12. Set a timetable for the given script; 

13. According to the schedule, the task will automatically be assigned to the client(s); 

14. The results of execution will be available in PRM Console. Select the required client/group and in the Tasks on 
<Group_Name/Client_Name> area will be available the assigned task, its current status, description, time and results 
of execution. 
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TROUBLESHOOTING 

Here you can find answers to the most frequently asked questions that might arise while using PRM. 

Q: During the installation of the PRM Client/ PRM Console I cannot get access to the PRM Storage shared folder. 

A: You should access the PRM Storage shared folder under credentials of a special user account (i.e. PRMAgent). You’ve actually 
got two ways to do that: 

 Log in to Windows and install PRM Client/PRM Console as PRMAgent; 

 Use your own user record to install PRM Client/PRM Console, but before that map the PRM Storage share as PRMAgent 
(thus you will be able to browse it during the installation). 

Q: I’ve installed PRM Client, but it isn’t shown in PRM Console. 

A: Make sure that you use an appropriate version of the PRM Client application. 

Q: I’ve installed PRM Client, but it isn’t shown in PRM Console and the client’s folder in PRM Storage is absent. 

A: Check the PRM Client log (typically “C:\Program Files\Paragon Software\Drive Backup\PRMClient\pclient.log”). You can find 
there details about the PRM Client configuration and error notifications. For example: 

 No mapping between account names and security IDs was done - probably a wrong user account was given during the 
PRM Client installation; 

 The specified service does not exist as an installed service - the PRM Client service isn’t running or absent; 

 Cannot create the .ini file "\\paraserver\prmstorage\00-10-18-24-9c-29\task.ini" - PRM Client cannot access PRM 
Storage. 

A: Check whether the PRM Client service is present and running (Computer Management > Services and Applications > Services 
> Paragon Remote Management Client). Here you can also change the user account used by PRM Console. 

A: Make sure you specified the proper user account to PRM Storage during the installation of PRM Client. 

 In Workgroup: make sure a PRM Storage user account is created on the PRM Client computer and it’s a local 
administrator; 

 In Domain: a PRM Storage user account has to be in a local administrators group on the PRM Client computer; 

 A PRM Storage user account shouldn’t contain spaces (i.e. PRMAgent, NOT PRM Agent). 

If a mistake found, please fix it and re-install PRM Client if needed. 

Q: After the computer restart PRM Console doesn’t start with the message “PRM Storage path. Is not valid PRM Storage” 

A: If you use PRM Console with Windows Vista or Windows Server 2008, please switch off User Account Control (UAC) for the 
user account used by PRM Console. 

Q: I use PRM Client without Drive Backup on a 64-bit Windows operating system. All operations that require the computer 
restart do not perform. 

A: Re-install PRM Client with Drive Backup (it’s obligatory under 64-bit OSes). 

Q: What useful entries does the task.ini file contain? 
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A: Below you can find several entries of this file with their notions: 

 Version - the PRM Client version; 

 DisplayName - a name of the PRM Client computer, which is shown on the PRM Console list (available to modify); 

 Features - a type of PRM Client (0x0 – Workstation, 0x0 – Server); 

 Tasks - a number of assigned tasks to PRM Client;  

Q: I’ve noticed that some assigned tasks have not been performed by PRM Client. 

A: Please make sure that PRM Storage is accessible when PRM Client is working. Even if PRM Client doesn’t use PRM Storage as a 
backup storage, it has to get access to the task.ini file and scripts files, which are kept inside PRM Storage. 
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